Back to overview
Degraded
Some services are degraded
Jul 07 at 02:36pm BST
Affected services
Germany - Game 1
Resolved
Jul 07 at 02:50pm BST
Game 1 - Appears to have recovered.
We will continue investigating and monitoring the situation.
Affected services
Germany - Game 1
Created
Jul 07 at 02:36pm BST
Germany - Game 1 experiencing issues.
Affected services
Germany - Game 1