Back to overview
Downtime

Major Service Outage

Oct 01 at 04:37pm BST
Affected services
VPS #1 - (Ryzen 9)

Resolved
Oct 02 at 09:10am BST

Services are now mostly operational again.

While global routing updates continue to settle, some users may still experience intermittent issues but the majority should have normal access.

We’ll keep monitoring until everything is fully stable.

Updated
Oct 02 at 07:32am BST

Services are now starting to come back online.

What to Expect:
It may take a few hours for internet providers around the world to update their records and recognize these new routes. Until those updates fully spread some users may regain access sooner than others this is normal when global internet routing changes are made.

We’ll continue to monitor closely as routing updates propagate worldwide.

Services should steadily return to normal throughout the day.

Thank you again for your patience!

Created
Oct 01 at 04:37pm BST

We are currently experiencing a major service outage affecting all services using the 143.14.89.0/24 IP range.

We have reached out to our internet provider to investigate the issue, and it appears they are experiencing widespread network problems impacting multiple companies and organizations. Unfortunately, this is completely out of our hands.

Our team is monitoring the situation closely and will provide updates as soon as more information becomes available. We apologize for the inconvenience and appreciate your patience.